Commit 41a13747 authored by Camilla Berglund's avatar Camilla Berglund
Browse files

Updated references to OS X (previously Mac OS X).

parent c8b01f61
......@@ -56,7 +56,7 @@ along with the library.
built along with the library.
#### Mac OS X specific options
#### OS X specific options
`GLFW_USE_CHDIR` determines whether `glfwInit` changes the current
directory of bundled applications to the `Contents/Resources` directory.
......
......@@ -206,6 +206,6 @@ it from the command-line.
The OpenGL framework contains both the OpenGL and GLU APIs, so there is nothing
special to do when using GLU. Also note that even though your machine may have
`libGL`-style OpenGL libraries, they are for use with the X Window System and
will *not* work with the Mac OS X native version of GLFW.
will *not* work with the OS X native version of GLFW.
*/
......@@ -112,14 +112,14 @@ context profiles. Where this extension is unavailable, setting the
`GLFW_OPENGL_PROFILE` hint to anything but zero will cause @ref glfwCreateWindow
to fail.
@section cmopat_osx OpenGL 3.2 on Mac OS X
@section cmopat_osx OpenGL 3.2 on OS X
Support for OpenGL 3.0 and above was introduced with Mac OS X 10.7, and even
then only forward-compatible OpenGL 3.2 core profile contexts are supported.
There is also still no mechanism for requesting debug contexts. Versions of
Mac OS X earlier than 10.7 support at most OpenGL version 2.1.
Support for OpenGL 3.0 and above was introduced with OS X 10.7, and even then
only forward-compatible OpenGL 3.2 core profile contexts are supported. There
is also still no mechanism for requesting debug contexts. Versions of OS
X earlier than 10.7 support at most OpenGL version 2.1.
Because of this, on Mac OS X 10.7, the `GLFW_CONTEXT_VERSION_MAJOR` and
Because of this, on OS X 10.7, the `GLFW_CONTEXT_VERSION_MAJOR` and
`GLFW_CONTEXT_VERSION_MINOR` hints will fail if given a version above 3.2, the
`GLFW_OPENGL_FORWARD_COMPAT` is required for creating OpenGL 3.2 contexts, the
`GLFW_OPENGL_DEBUG_CONTEXT` hint is ignored and setting the
......
......@@ -220,7 +220,7 @@ static void centerCursor(_GLFWwindow *window)
@end
// Translates Mac OS X key modifiers into GLFW ones
// Translates OS X key modifiers into GLFW ones
//
static int translateFlags(NSUInteger flags)
{
......@@ -238,7 +238,7 @@ static int translateFlags(NSUInteger flags)
return mods;
}
// Translates a Mac OS X keycode to a GLFW keycode
// Translates a OS X keycode to a GLFW keycode
//
static int translateKey(unsigned int key)
{
......
......@@ -74,7 +74,7 @@ int _glfwCreateContext(_GLFWwindow* window,
{
unsigned int attributeCount = 0;
// Mac OS X needs non-zero color size, so set resonable values
// OS X needs non-zero color size, so set resonable values
int colorBits = fbconfig->redBits + fbconfig->greenBits + fbconfig->blueBits;
if (colorBits == 0)
colorBits = 24;
......@@ -93,7 +93,7 @@ int _glfwCreateContext(_GLFWwindow* window,
if (wndconfig->glMajor == 3 && wndconfig->glMinor < 2)
{
_glfwInputError(GLFW_VERSION_UNAVAILABLE,
"NSOpenGL: The targeted version of Mac OS X does not "
"NSOpenGL: The targeted version of OS X does not "
"support OpenGL 3.0 or 3.1");
return GL_FALSE;
}
......@@ -103,7 +103,7 @@ int _glfwCreateContext(_GLFWwindow* window,
if (!wndconfig->glForward)
{
_glfwInputError(GLFW_VERSION_UNAVAILABLE,
"NSOpenGL: The targeted version of Mac OS X only "
"NSOpenGL: The targeted version of OS X only "
"supports OpenGL 3.2 and later versions if they "
"are forward-compatible");
return GL_FALSE;
......@@ -112,7 +112,7 @@ int _glfwCreateContext(_GLFWwindow* window,
if (wndconfig->glProfile != GLFW_OPENGL_CORE_PROFILE)
{
_glfwInputError(GLFW_VERSION_UNAVAILABLE,
"NSOpenGL: The targeted version of Mac OS X only "
"NSOpenGL: The targeted version of OS X only "
"supports OpenGL 3.2 and later versions if they "
"use the core profile");
return GL_FALSE;
......@@ -123,7 +123,7 @@ int _glfwCreateContext(_GLFWwindow* window,
if (wndconfig->glMajor > 2)
{
_glfwInputError(GLFW_VERSION_UNAVAILABLE,
"NSOpenGL: The targeted version of Mac OS X does not "
"NSOpenGL: The targeted version of OS X does not "
"support OpenGL version 3.0 or above");
return GL_FALSE;
}
......@@ -133,7 +133,7 @@ int _glfwCreateContext(_GLFWwindow* window,
if (wndconfig->glRobustness)
{
_glfwInputError(GLFW_VERSION_UNAVAILABLE,
"NSOpenGL: Mac OS X does not support OpenGL robustness "
"NSOpenGL: OS X does not support OpenGL robustness "
"strategies");
return GL_FALSE;
}
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment